You are currently browsing legacy 1.0 version of documentation. Click here to switch to the newest 4.2 version.

We can help you with migration to the latest RavenDB

Contact Us Now
see on GitHub

System requirements

RavenDB comes in several flavors. Listed below are the system requirements for each.

Lightweight client

  • Min: .NET Framework 3.5 Client Profile.
  • Recommended: .NET Framework 4.0 Client Profile
  • The client doesn't require Windows and can run on Mono.

Silverlight client

  • Silverlight 4 or 5

RavenDB server / Embedded

  • .Net framework 4
  • Windows